Pseudocódigo

El principal objetivo es representar la solución a un algoritmo de la forma mas detallada posible y en un lenguaje muy similar al que luego sera programado.

A continuación les dejo un ejemplo de como realizar un pseudocódigo para su mejor comprensión.

La problemática es la siguiente:

Escribir el pseudocódigo de un programa, que le permita al usuario ingresar las notas de cierta cantidad de alumnos, y que luego muestre la cantidad de aprobados (notas mayores o iguales a 6.00), la cantidad de reprobados.

Para comenzar a escribir nuestro pseudocódigo identificamos los datos que utilizaremos.

Permita al usuario : Esto quiere decir que debemos pedirle los datos a nuestro usuario.

Cierta cantidad de Alumnos: No tenemos la cantidad podemos pedirla, ingresarla nosotros o simplemente preguntar si se desea continuar luego de cada ingreso de notas (para este caso utilizaremos  la última opción).

Muestre la cantidad de aprobados y reprobados:  Al final debemos mostrar la cantidad de alumnos que aprobaron y reprobaron.

Notas mayores o iguales a 6.00:  El promedio de las notas ingresadas por alumno sera nuestra validación para saber si aprobó o no el alumno.

Comencemos…

  • Definir nombre proceso:  

  • Establecemos nuestras variables a utilizar:

  • Para que nuestro pseudocódigo logre funcionar necesitaremos dar un valor inicial a nuestras variables:

  • Hasta este momento solo hemos declarado las variables que utilizaremos para realizar nuestro proceso. Como anteriormente se decidió preguntar al usuario cuando terminar el ingreso de notas de los alumnos procedemos a preguntarle con la siguiente sentencia:

  •  A continuación necesitaremos crear un ciclo que se mantenga mientras el usuario lo desee utilizando la pregunta recién creada. 

  •  Una vez que hemos creado este ciclo debemos realizar algo para que el usuario ingrese las notas del alumno, para esto existen muchas opciones sin embargo les enseñare el uso de una sentencia llamada Repetir la cual consiste en realizar una misma acción hasta que se cumpla una condición que en este caso sera el limite de notas por ingresar.

  •  Saliendo del ciclo debemos calcular el promedio de notas del alumno y luego establecer si esta aprobado o no.

  •  Luego antes de salir de nuestro ciclo Mientras incrementamos en 1 nuestros alumnos y volvemos a preguntar si desea ingresar notas para el siguiente alumno.

  •  Por ultimo cerramos nuestro ciclo Mientras y mostramos los datos al usuario finalizando posteriormente el proceso.

Con todo esto ya tenemos listo nuestro primer pseudocódigo. Aclaro que no existen validaciones y es una de las posibles soluciones solo buscamos enseñar como crear un pseudocódigo desde el principio. Les recomiendo utilizar el programa  PSeInt lo pueden descargar haciendo clic aqui. Con este programa pueden crear sus pseudocódigos tranquilamente y probar el funcionamiento, ademas como algo adicional crea el diagrama de flujos automáticamente.

A continuación les dejo el código completo

Estamos atentos a cualquier duda a comentario.

Saludos espero les haya gustado.

Publicado en Otros Aportes
22 Comentarios en “Pseudocódigo
  1. Alicia dice:

    hola solictuo tu ayuda
    como puedo hacer este programa es parecido y menos complicado que el que expones

    Se desea leer las calificaciones de una clase de fisica(con 10 alumnos) y determinar la cantidad de alumnos aprobados(>=6) y de alumnos reprobados(<6)

    de antemano gracias

    • Victor Riquelme Victor Riquelme dice:

      Esta es una posible solución a tu problema espero sea lo que necesitas.

      Proceso notas_alumnos

      Definir notas_alumnos[10];
      Definir aprobados Como Real;
      Definir reprobados Como Real;
      Definir posicion Como Numerico;

      notas_alumnos(0) <- 5;
      notas_alumnos(1) <- 4;
      notas_alumnos(2) <- 5;
      notas_alumnos(3) <- 6;
      notas_alumnos(4) <- 7;
      notas_alumnos(5) <- 6;
      notas_alumnos(6) <- 7;
      notas_alumnos(7) <- 4;
      notas_alumnos(8) <- 3;
      notas_alumnos(9) <- 5;

      aprobados<-0;
      reprobados<-0;
      posicion<-0;

      Hasta Que posicion = 9

      Si nota(posicion) < 6.0 Entonces

      reprobados <- reprobados+1;

      Sino

      aprobados <- aprobados+1;

      FinSi

      posicion <- posicion +1;

      FinMientras

      Escribir "Cantidad de Alumnos Aprobados ", aprobados ;
      Escribir "Cantidad de Alumnos Reprobados ", reprobados ;

      FinProceso

  2. Alicia dice:

    gracias por tus comentarios victor

    mi problema dice lo siguiente

    Actividad 3. Diseño de un algoritmo con estructuras repetitivas

    Se desea leer las calificaciones de una clase de fisica(con 10 alumnos) y determinar la cantidad de alumnos aprobados(>=6) y de alumnos reprobados(<6)

  3. Alicia dice:

    me pone error en estos renglones

    Definir notas_alumnos[10];
    Definir aprobados Como Real;
    Definir reprobados Como Real;
    Definir posicion Como Numerico;

  4. Victor Riquelme Victor Riquelme dice:

    Alicia que utilizas para validar el pseudocodigo?

    • alicia dice:

      hola gracias por responder utiliso el pseint
      lo paso a pseint y lo corro para verificar errores automaticamente por el mismo programa y despues de no haber errores saco el diagrama de flujo

      • Victor Riquelme Victor Riquelme dice:

        Bueno Alicia te comento el ejemplo que te di fue un tipo de pseudocódigo, sin embargo para PseInt la manera de definir arreglos es:

        Definir ARREGLO Como Enteros;
        Dimension ARREGLO[100];

        y la manera de recorrerlo seria

        Definir VAL_MAYOR Como Enteros;

        Para I< -0 Hasta 99 Hacer Si ARREGLO[I]>VAL_MAYOR Entonces

        VAL_MAYOR<-ARREGLO[i]; FinSi FinPara Este código solo valida el mayor elemento de una matriz o dimensión, obviamente debes llenarla para poder realizar esto. Saludos

    • alicia dice:

      te mando lo que tengo
      has de cuenta esto pero ademas del promedio que me diga cuantas calkificaciones fueron aprobatorioas y cuantas reprobatoria.

  5. alicia dice:

    // Calcula el promedio de una lista de N calificaciones

    Proceso Promedio

    Escribir “Ingrese la cantidad de calificaciones a promediar:”;
    Leer n;

    acum<-0;

    Para i<-1 Hasta n Hacer
    Escribir "Ingrese la calificacion ",i,":";
    Leer dato;
    acum=60
    Entonces
    escribir “aprobado”;
    sino
    escribir “reprobado”;

    FinSi

    FinPara

    prom<-acum/n;

    Escribir "El promedio de las calificaciones ingresadas es de: ",prom;

    FinProceso

    • alicia dice:

      lo que necesitas es iniciar un contador de reprobados y aprobados e ir acumulando el resultado para que al final te muestre las calificaciones aprobatorias y las reprobatorias

      victor requelme es muy bueno para estos asuntos

      y loque queres es la programacion no el pseudocodigo

      saludos amigos

      • Victor Riquelme Victor Riquelme dice:

        Definir Aprobados,Reprobados,NotasAlumnosFisica,I Como Enteros;

        NotasAlumnosFisica[10];

        Aprobados< -0; Reprobados<-0; NotasAlumnosFisica[0]<- 7; NotasAlumnosFisica[1]<- 4; NotasAlumnosFisica[2]<- 5; NotasAlumnosFisica[3]<- 6; NotasAlumnosFisica[4]<- 7; NotasAlumnosFisica[5]<- 7; NotasAlumnosFisica[6]<- 2; NotasAlumnosFisica[7]<- 1; NotasAlumnosFisica[8]<- 2; NotasAlumnosFisica[9]<- 3; Para I<-0 Hasta 9 Hacer Si NotasAlumnosFisica[I] >= 6 Entonces

        Aprobados<-Aprobados +1; Sino Reprobados<-Reprobados +1; FinSi FinPara Escribir "La cantidad de alumnos aprobados en la clase de Fisica fueron ",Aprobados; Escribir "La cantidad de alumnos reprobados en la clase de Fisica fueron ",Reprobados; Como siempre te comento esta es una Posible solución. Saludos

  6. william omar dice:

    me pueden ayudar en realizar un programa que me permita leer los datos de 10 alumnos (mun_seccion y sexo), luego calcule y muestre:
    – total de varones por cada seccion, total de mujeres por cada seccion.
    – total general de varones, total general de mujeres.
    – se sabe que solo existen 3 secciones : 1, 2 y 3
    – para el sexo: H=varones y M=mujeres

  7. Raúl dice:

    Hola! necesito este mismo pero que sea de esta forma, que me calcule 4 notas para 5 estudiantes (Osea cada estudiante 4 notas), para aprobar el promedio debe ser mayor que 80, y que me diga cuantos aprobaron y cuantos no, gracias!

  8. luzmila dice:

    hola solictuo tu ayuda
    como puedo hacer este programa es parecido y menos complicado que el que expones

    realice un programa para leer las calificaciones de N alumnos y determine el umero e aprobados y reprobados

    de antemano gracias

  9. DIEGO dice:

    Hola solicito tu ayuda urgente bueno este es el problema
    Escribir un algoritmo que permita el ingreso de 5 notas y determine:
    – La cantidad de notas Buenas.
    – La cantidad de notas Regulares.
    – La cantidad de notas Muy Buenas.
    – La cantidad de notas Deficientes.
    – Suma de todas las notas.
    – El promedio de las 5 notas.

    -ESCALA NOTAS
    MUY BUENO 17 – 20
    BUENO 14 – 16
    REGULAR 11 – 13
    DEFICIENTE 06 – 10
    MUY DEFICIENTE 00 – 05

    Este es el problema he estado intentandolo. Yo puedo sacar normal el promedio las suma pero me resulta difícil saber la cantidad de cada nota.Soy nuevo en la programacion y uso el PSeint

  10. MARIVICK dice:

    hola buenas tardes víctor disculpa la molestia necesito tu ayuda pare resolver este pseudocodigo me lo mandaron sin el problema o ejercicio solo el pseudocodigo pero ne lo mandaron con errores y el profesor me manda a rasolverlo sin los errores …el pseudocodigo es el siguiente …

    ALGORITMO Promedio secciones 3
    var promedio:IR
    nota 1,alumno,nota 2 notas 3 N
    Aprobado, Reprovado:N
    inicio
    promedio=0
    Repetir
    leer: Nota1,Nota2,Nota3
    promedio=Nota1 +Nota2+Nota3
    3
    si promedio > 10

    Aprobado=Aprobado+1
    si no
    Reprobado=Reprobado+
    alumno:alumno+1

    hasta (alumno >11)
    Mostrar “Aprobados”, Aprobados
    mostrar “Reprobados”,Reprobados
    FIN

  11. rodrigo dice:

    hola nesecito tu ayuda con esta pregunta
    crear un algoritmo con ingreso de 10 promedios y luego me diga cuantos aprobaron y cuantos desaprobaron ya que el promedio para aprobar es de 13

  12. rodrigo dice:

    con el ciclo mientras en pseint
    y de ante mano te lo agradesco

  13. marisa dice:

    hola necesito hacer un programa que lea N cantidad de notas de estudiantes con su respectiva nota final que esten ordenados de forma ascendente y muestre el promedio de cada uno,ademas totalizar la cantidad de aprobados y reprobados en escala del 1 al 5 y como minima 3.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

*